Ein Testproblem – mit den Nerven am Ende

Ich habe mich jetzt zwei Tage lang nur rumgeärgert und bin bald verzweifelt. Dabei ist es doch so einfach eine Änderung an seiner Webseite zu testen.
Ja, schön wäre es. Die meisten Änderungen kann man ja in der Vorschau eines ordentlichen Webeditors sehen – also in meinem Fall im CMS meines Providers. Aber bestimmte Dinge eben nicht. Das hört meistens auf, wenn man mit Scripten arbeitet oder/und mit Cookies. Da muss man schon die Webseite veröffentliche und im Browser aufrufen. Und zwar in verschiedenen. Und, das werdet ihr sicher auch machen, man testet ja nicht nur einmal, sondern ein paarmal. Das ist ja oftmals sowieso zwingend notwendig. Und genau daran bin ich fast verzweifelt.

Denn der Browser ruft die Seite beim zweiten mal ja nicht vom Server ab, sondern aus seinem Cache. Also muss man jedesmal den Browser-Cache und evtl. die Cookies, am besten immer gleich alles, löschen, bevor man einen Testaufruf macht. Besonders dann, wenn man ein kniffliges Problem hat und sich an die Lösung herantasten muss. Denn einmal das Löschen vergessen und man hat vorher noch einmal etwas geändert, erscheint die Version von vor der Änderung und man denkt es hat nicht funktioniert. Da kann man sich zu Tode testen. Zum Glück kann man bei den aktuellen Browsern das Einstellungsmenü zum Löschen des Caches als separaten Tab öffnen. Trotzdem nervt es.

Aber das ist ja noch das kleinere Übel. Wirklich verzweifelt bin ich an etwas ganz anderem.

Ich habe also den Browser-Cache gelöscht und die Seite aufgerufen. Alles OK. Dann F5 – erneuter Aufruf. Nix ging. Nochmal F5 – nix. Alles wie vor der Änderung. Wieder kontrolliert und geändert, Cache gelöscht. Gleiches Spiel. Einmal geht es, danach nicht mehr. Wo ist der Fehler? Ich hab mich bald tot gesucht. Obwohl ich doch jedesmal den BrowserCache gelöscht habe.

Dann habe ich zu einem Trick gegriffen und jedesmal nach einer Änderung die Überschrift auf meiner Webseite geändert – einfach einen zusätzlichen Buchstaben oder eine Ziffer hinzugefügt. Und dann hat es Klick gemacht. Beim ersten Aufruf nach einer Änderung hat der Browser tatsächlich die neue Version aufgerufen. Ab dem zweiten Aufruf hat er die vorherige Version aus einem Cache des Webservers aufgerufen. Eigentlich sollte dort auch sofort die zuletzt geladene Version liegen. Dem war aber nicht so. Und darauf soll erst einmal einer kommen.

Und das obwohl ich in meinen Projekten standardmäßig den Meta-Tag „nocache“ einbaue. Der wurde also mal einfach so ignoriert.

Also wenn ihr mal in einer ähnlichen Situation seit und langsam anfangt zu verzweifeln – ändert mal die Überschrift.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.